Widespread AWS Outage Affecting Jellyfish App

Incident Report for Jellyfish

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 11:35 UTC

Update

All services are operational. We are continuing to monitor.
Posted Oct 21, 2025 - 02:08 UTC

Monitoring

The AWS Incident has been resolved, and Jellyfish infrastructure is operational. We are continuing to monitor some dependencies on other 3rd parties. Data processing is still delayed.
Posted Oct 21, 2025 - 00:44 UTC

Identified

AWS is rolling mitigations through us-east. The Jellyfish web app is back, though some underlying services like DFO report generation and data ingestion may still be affected. We are continuing to monitor the situation and will post updates here.
Posted Oct 20, 2025 - 18:59 UTC

Investigating

Ongoing widespread AWS outage is affecting some Jellyfish services. The web app is currently unavailable and we are actively working to mitigate.
Posted Oct 20, 2025 - 13:56 UTC
This incident affected: Web Application and Data Ingestion.